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Creating a data fi le and 

entering data

There are a number of stages in the process of setting up a data fi le and analysing the 
data. The fl ow chart shown on the next page outlines the main steps that are needed. 
In this chapter I will lead you through the process of creating a data fi le and entering 
the data.

To prepare a data fi le, three key steps are covered in this chapter:

• Step 1. The fi rst step is to check and modify, where necessary, the options that 
SPSS uses to display the data and the output that is produced.

• Step 2. The next step is to set up the structure of the data fi le by ‘defi ning’ the 
variables.

• Step 3. The fi nal step is to enter the data—that is, the values obtained from each 
participant or respondent for each variable.

To illustrate these procedures I have used the data fi le survey4ED.sav, which is 
described in the Appendix. The codebook used to generate these data is also provided 
in the Appendix.

Data fi les can also be ‘imported’ from other spreadsheet-type programs (e.g. 
Excel). This can make the data entry process much more convenient, particularly 
for students who don’t have SPSS on their home computers. You can set up a basic 
data fi le on Excel and enter the data at home. When complete, you can then import 
the fi le into SPSS and proceed with the data manipulation and data analysis stages. 
The instructions for using Excel to enter the data are provided later in this chapter.
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CHANGING THE SPSS ‘OPTIONS’
Before you set up your data fi le, it is a good idea to check the SPSS options that govern 
the way your data and output are displayed. The options allow you to defi ne how your 
variables will be displayed, the type of tables that will be displayed in the output and 
many other aspects of the program. Some of this will seem confusing at fi rst, but once 
you have used the program to enter data and run some analyses you may want to refer 
back to this section.

Flow chart of data analysis process
Prepare codebook (Chapter 2)

Set up structure of data fi le (Chapter 4)

Enter data (Chapter 4)

Screen data fi le for errors (Chapter 5)

Explore data using descriptive statistics and graphs (Chapters 6 and 7)

Modify variables for further analyses (Chapter 8)

Conduct statistical analyses to  Conduct statistical analyses to
explore relationships (Part 4)  compare groups (Part 5)

Correlation (Chapter 11) Non-parametric techniques (Chapter 16)
Partial correlation (Chapter 12) T-tests (Chapter 17)
Multiple regression (Chapter 13) Analysis of variance (Chapters 18, 19, 20)
Logistic regression (Chapter 14) Multivariate analysis of variance (Chapter 21)
Factor analysis (Chapter 15) Analysis of covariance (Chapter 22)
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tables after they appear in your output, but you can modify many aspects (e.g. font 
sizes, column width) by using the Pivot Table Editor. This can be activated by double-
clicking on the table that you wish to modify.

Once you have made all the changes you wish to make on the various Options 
tabs, click on OK. You can then proceed to defi ne your variables and enter your data.

DEFINING THE VARIABLES
Before you can enter your data, you need to tell SPSS about your variable names and 
coding instructions. This is called ‘defi ning the variables’. You will do this in the Data 
Editor window (see Figure 4.2). The Data Editor window consists of two different 
views: Data View and Variable View. You can move between these two views using the 
little tabs at the bottom left-hand side of the screen.

You will notice that in the Data View window each of the columns is labelled var. 
These will be replaced with the variable names that you listed in your codebook (see 
Figure 4.2). Down the side you will see the numbers 1, 2, 3 and so on. These are the 
case numbers that SPSS assigns to each of your lines of data. These are not the same 
as your ID numbers, and these case numbers change if you sort your fi le or split your 
fi le to analyse subsets of your data.

Procedure for defi ning your variables
To defi ne each of the variables that make up your data fi le, you fi rst need to click 
on the Variable View tab at the bottom left of your screen. In this view (see 
Figure 4.3) the variables are listed down the side, with their characteristics listed 
along the top (name, type, width, decimals, label etc.).

Your job now is to defi ne each of your variables by specifying the required infor-
mation for each variable listed in your codebook. Some of the information you will 
need to provide yourself (e.g. name); other bits are provided automatically using 

Figure 4.2
Data Editor window
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default values. These default values can be changed if necessary. The key pieces of infor-
mation that are needed are described below. The headings I have used correspond to 
the column headings displayed in the Variable View. I have provided the simple step-
by-step procedures below; however, there are a number of shortcuts that you can use 
once you are comfortable with the process. These are listed later, in the section headed 
‘Optional shortcuts’. You should become familiar with the basic techniques fi rst.

Name
In this column, type in the brief variable name that will be used to identify each of the 
variables in the data fi le (listed in your codebook). Keep these variable names as short as 
possible, not exceeding 64 characters. They must follow the naming conventions speci-
fi ed by SPSS (listed in Chapter 2). Each variable name must be unique, must start with 
a letter, and cannot contain spaces or symbols. For ideas on how to label your variables, 
have a look at the codebooks provided in the Appendix. These list the variable names 
used in data fi les that accompany this book (see p. viii for details of these fi les).

Type
The default value for Type that will appear automatically as you enter your fi rst variable 
name is Numeric. For most purposes, this is all you will need to use. There are some 
circumstances where other options may be appropriate. For example, if you need to enter 
text information (e.g. a person’s surname), you need to change the type to String. A Date 
option is also available if your data includes dates. To change the variable type, click in the 
cell and a box with three dots should appear giving you the options available. You can also 
use this window to adjust the width of the variable and the number of decimal places.

Width
The default value for Width is 8. This is usually suffi cient for most data. If your 
variable has very large values (or you have requested a string variable), you may need 
to change this default value; otherwise, leave it as is.

Figure 4.3
Variable View
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Decimals
The default value for Decimals is usually 2 (however, this can be changed using the 
Options facility described earlier in this chapter). If your variable has decimal places, 
change this to suit your needs.

Label
The Label column allows you to provide a longer description for your variable than 
used in the Name column. This will be used in the output generated from the analyses 
conducted by SPSS. For example, you may wish to give the label Total Optimism to 
your variable TOPTIM.

Values
In the Values column you can defi ne the meaning of the values you have used to code 
your variables. I will demonstrate this process for the variable Sex.

1. Click on the three dots on the right-hand side of the cell. This opens the 
Value Label dialogue box.

2. Click in the box marked Value. Type in 1.
3. Click in the box marked Label. Type in Male.
4. Click on Add. You will then see in the summary box: 1=Male.
5. Repeat for Females: Value: enter 2, Label: enter Female. Add.
6. When you have fi nished defi ning all the possible values (as listed in your 

codebook), click on OK.

Missing
Sometimes researchers assign specifi c values to indicate missing values for their data. 
This is not essential—SPSS will recognise any blank cell as missing data. So if you 
intend to leave a blank when a piece of information is not available, it is not necessary 
to do anything with this Variable View column.

If you do intend to use specifi c missing value codes (e.g. 99=not applicable), you 
must specify this value in the Missing section, otherwise SPSS will use the value as a 
legitimate value in any statistical analyses. Click in the cell and then on the shaded box 
with three dots that appears. Choose the option Discrete missing values and type the 
value (e.g. 99) in the space provided. Up to three values can be specifi ed. Click on OK.

If you are using these special codes, it is also a good idea to go back and label these 
values in the Values column.

Columns
The default column width is usually set at 8, which is suffi cient for most purposes. 
Change it only if necessary to accommodate your values or long variable names.
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Align
The alignment of the columns is usually set at ‘right’ alignment. There is no need to 
change this.

Measure
The column heading Measure refers to the level of measurement of each of your vari-
ables. The default is Scale, which refers to continuous data measured at interval or ratio 
level of measurement. If your variable consists of categories (e.g. sex), click in the cell and 
then on the arrow key that appears. Choose Nominal for categorical data and Ordinal if 
your data involve rankings or ordered values (e.g. level of education completed).

Optional shortcuts
The process described above can be rather tedious if you have a large number of 
variables in your data fi le. There are a number of shortcuts you can use to speed up 
the process. If you have a number of variables that have the same ‘attributes’ (e.g. 
type, width, decimals), you can set the fi rst variable up correctly and then copy these 
attributes to one or more other variables.

Copying variable defi nition attributes to one other variable

1.  In Variable View, click on the cell that has the attribute you wish to copy 
(e.g. Width).

2. From the menu, click on Edit and then Copy.
3. Click on the same attribute cell for the variable you wish to apply this to.
4. From the menu, click on Edit and then Paste.

Copying variable defi nition attributes to a number of other 
variables

1.  In Variable View, click on the cell that has the attribute you wish to copy 
(e.g. Width).

2. From the menu, click on Edit and then Copy.
3. Click on the same attribute cell for the fi rst variable you wish to copy to 

and then, holding your left mouse button down, drag the cursor down 
the column to highlight all the variables you wish to copy to.

4. From the menu, click on Edit and then Paste.

Setting up a series of new variables all with the same attributes
If your data consists of scales made up of a number of individual items, you can 
create the new variables and defi ne the attributes of all of these items in one go. The 
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procedure is detailed below, using the six items of the Optimism Scale as an example 
(optim1 to optim6). If you want to practise this as an exercise, you should start a new 
data fi le (File, New, Data).

1.  In Variable View, defi ne the attributes of the fi rst variable (optim1) 
following the instructions provided earlier. This would involve defi ning 
the value labels 1=strongly disagree, 2=disagree, 3=neutral, 4=agree, 
5=strongly agree.

2.  With the Variable View selected, click on the row number of this variable 
(this should highlight the whole row).

3. From the menu, select Edit and then Copy.
4. Click on the row number of the next empty row.
5. From the menu, select Edit and then Paste Variables.
6.  In the dialogue box that appears, enter the number of additional 

variables you want to add (in this case, 5). Enter the prefi x you wish to 
use (optim) and the number you wish the new variables to start on (in this 
case, 2). Click on OK.

This will give you fi ve new variables (optim2, optim3, optim4, optim5 and optim6).
To set up all of the items in other scales, just repeat the process detailed above 

(e.g. sest1 to sest10 for the self-esteem items). Remember, this procedure is suitable 
only for items that have all the same attributes; it is not appropriate if the items have 
different response scales (e.g. if some are categorical and others continuous), or if the 
values are coded differently.

ENTERING DATA
Once you have defi ned each of your variable names and given them value labels (where 
appropriate), you are ready to enter your data. Make sure you have your codebook ready.

Procedure for entering data
1.  To enter data, you need to have the Data View active. Click on the Data 

View tab at the bottom left-hand side of the screen of the Data Editor 
window. A spreadsheet should appear with your newly defi ned variable 
names listed across the top.

2. Click on the fi rst cell of the data set (fi rst column, fi rst row).
3. Type in the number (if this variable is ID, this should be 1).
4.  Press the right arrow key on your keyboard; this will move the cursor into 

the second cell, ready to enter your second piece of information for case 
number 1.
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5.  Move across the row, entering all the information for case 1, making sure 
that the values are entered in the correct columns.

6.  To move back to the start, press the Home key on your keyboard (on some 
computers you may need to hold the Ctrl key or the Fn key down and 
then press the Home key). Press the down arrow to move to the second 
row, and enter the data for case 2.

7.  If you make a mistake and wish to change a value, click in the cell that 
contains the error. Type in the correct value and then press the right 
arrow key.

After you have defi ned your variables and entered your data, your Data Editor window 
should look something like that shown previously in Figure 3.1.

If you have entered value labels for some of your variables (e.g. Sex: 1=male, 
2=female), you can choose to have these labels displayed in the Data Editor window 
instead of just the numbers. To do this, click on View from the menu and select the 
option Value Labels. This option can also be activated during the data entry process so 
that you can choose an option from a drop-down menu, rather than typing a number 
in each cell. This is slower, but does ensure that only valid numbers are entered. To 
turn this option off, go to View and click on Value Labels again to remove the tick.

MODIFYING THE DATA FILE
After you have created a data fi le, you may need to make changes to it (e.g. to add, 
delete or move variables, or to add or delete cases). Make sure you have the Data 
Editor window open on the screen, showing Data View.

Delete a case
Move down to the case (row) you wish to delete. Position your cursor in the shaded 
section on the left-hand side that displays the case number. Click once to highlight 
the row. Press the Delete button on your computer keyboard. You can also click on the 
Edit menu and click on Clear.

Insert a case between existing cases
Move your cursor to a cell in the case (row) immediately below where you would like 
the new case to appear. Click on the Edit menu and choose Insert Cases. An empty 
row will appear in which you can enter the data of the new case.

Delete a variable
Position your cursor in the shaded section (which contains the variable name) above the 
column you wish to delete. Click once to highlight the whole column. Press the Delete 
button on your keyboard. You can also click on the Edit menu and click on Clear.



Creating a data fi le and entering data   37

Insert a variable between existing variables
Position your cursor in a cell in the column (variable) to the right of where you would 
like the new variable to appear. Click on the Edit menu and choose Insert Variable. 
An empty column will appear in which you can enter the data of the new variable.

Move an existing variable(s)
In the Data Editor window, have the Variable View showing. Highlight the variable 
you wish to move by clicking in the left-hand margin. Click and hold your left mouse 
button and then drag the variable to the new position (a red line will appear as you 
drag). Release the left mouse button when you get to the desired spot.

DATA ENTRY USING EXCEL
Data fi les can be prepared in the Microsoft Excel program and then imported into 
SPSS for analysis. This is great for students who don’t have access to SPSS at 
home. Excel usually comes as part of the Microsoft Offi ce package—check under All 
Programs in your Start menu. The procedure for creating a data fi le in Excel and 
then importing it into SPSS is described below. If you intend to use this option you 
should have at least a basic understanding of Excel, as this will not be covered here.

Warning: Excel can cope with only 256 columns of data (or variables). If your data 
fi le is likely to be larger than this, it is probably easier to set it up in SPSS rather than 
convert from Excel to SPSS later. Alternatively, you can use different Excel spread-
sheets (each with the ID as the fi rst variable), convert each to SPSS separately, then 
merge the fi les in SPSS later (see instructions in the next section).

Step 1: Set up the variable names

Set up an Excel spreadsheet with the variable names in the fi rst row across 
the page. The variable names must conform to the SPSS rules for naming 
variables (see Chapter 2).

Step 2: Enter the data

1.  Enter the information for the fi rst case on one line across the page, using 
the appropriate columns for each variable.

2.  Repeat for each of the remaining cases. Don’t use any formulas or other 
Excel functions. Remember to save your fi le regularly.

3.  Click on File, Save. In the section marked Save as Type, make sure 
Microsoft Excel Workbook is selected. Type in an appropriate fi le name.
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Step 3: Converting to SPSS

1. After you have entered the data, save your fi le and then close Excel.
2.  Start SPSS and select File, Open, Data from the menu at the top of the 

screen.
3.  In the section labelled Files of type, choose Excel. Excel fi les have a .xls or 

.xlsx extension. Find the fi le that contains your data. Click on it so that it 
appears in the File name section.

4.  Click on the Open button. A screen will appear labelled Opening Excel 
Data Source. Make sure there is a tick in the box Read variable names 
from the fi rst row of data. Click on OK.

The data will appear on the screen with the variable names listed across the top. You 
will then need to save this new SPSS fi le.

Step 4: Saving as an SPSS fi le

1. Choose File, and then Save As from the menu at the top of the screen.
2.  Type in a suitable fi le name. Make sure that the Save as Type is set at 

SPSS Statistics (*.sav). Click on Save.
3.  In the Data Editor, Variable view, you will now need to defi ne each of 

the Labels, Values and Measure information (see instructions presented 
earlier). You may also want to reduce the width of the columns as they 
often come in from Excel with a width of 11.

When you wish to open this fi le later to analyse your data using SPSS, make sure you 
choose the fi le that has a .sav extension (not your original Excel fi le that has a .xls 
extension).

MERGE FILES
There are times when it is necessary to merge different data fi les. SPSS allows you to 
merge fi les by adding additional cases at the end of your fi le, or to merge additional 
variables for each of the cases in an existing data fi le (e.g. when Time 2 data becomes 
available). This second option is also useful when you have Excel fi les with infor-
mation spread across different spreadsheets that need to be merged by ID.

To merge fi les by adding cases
This procedure will allow you to merge fi les that have the same variables, but differ-
ent cases; for example, where the same information is recorded at two different sites 
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USEFUL SPSS FEATURES
There are many useful features of SPSS that can be used to help with analyses, and to 
save you time and effort. I have highlighted a few of the main ones in the following 
sections.

Sort the data fi le
You can ask SPSS to sort your data fi le according to values on one of your variables 
(e.g. sex, age).

1. Click on the Data menu, choose Sort Cases and specify which variable will 
be used to sort by. Choose either Ascending or Descending. Click on OK.

2. To return your fi le to its original order repeat the process, asking SPSS to 
sort the fi le by ID.

Split the data fi le
Sometimes it is necessary to split your fi le and to repeat analyses for groups (e.g. males and 
females) separately. This procedure does not physically alter your fi le in any permanent 
manner. It is an option you can turn on and off as it suits your purposes. The order in 
which the cases are displayed in the data fi le will change, however. You can return the data 
fi le to its original order (by ID) by using the Sort Cases command described above.

1. Click on the Data menu and choose the Split File option.
2. Click on Compare groups and specify the grouping variable (e.g. sex). 

Click on OK.

For the analyses that you perform after this split fi le procedure, the two groups (in this 
case, males and females) will be analysed separately.

Important: when you have fi nished the analyses, you need to go back and turn the 
Split File option off.

1. Click on the Data menu and choose the Split File option.
2. Click on the fi rst dot (Analyze all cases, do not create groups). Click on OK.

Select cases
For some analyses, you may wish to select a subset of your sample (e.g. only males).

1. Click on the Data menu and choose the Select Cases option.
2. Click on the If condition is satisfi ed button.
3. Click on the button labelled IF.
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4. Choose the variable that defi nes the group that you are interested in (e.g. sex).
5. Click on the arrow button to move the variable name into the box. Click 

on the = key from the keypad displayed on the screen.
6. Type in the value that corresponds to the group you are interested in 

(check with your codebook). For example, males in this sample are coded 
1, therefore you would type in 1. The command line should read: sex=1.

7. Click on Continue and then OK.

For the analyses (e.g. correlation) that you perform after this Select Cases procedure, 
only the group that you selected (e.g. males) will be included.

Important: when you have fi nished the analyses, you need to go back and turn the 
Select Cases option off, otherwise it will apply to all analyses conducted.

1. Click on the Data menu and choose Select Cases option.
2. Click on the fi rst All cases option. Click on OK.

USING SETS
With large data fi les, it can be a pain to have to scroll through lots of variable names 
in SPSS dialogue boxes to reach the ones that you want to analyse. SPSS allows you to 
defi ne and use ‘sets’ of variables. This is particularly useful in the survey4ED.sav data 
fi le, where there are lots of individual items that are added to give total scores, which 
are located at the end of the fi le. In the following example, I will establish a set that 
includes only the demographic variables and the scale totals.

1. Click on Utilities from the menu and choose Defi ne Variable Sets.
2. Choose the variables you want in your set from the list. Include ID, the 

demographic variables (sex through to smoke number), and then all the 
totals at the end of the data fi le from Total Optimism onwards. Move 
these into the Variables in Set box.

3. In the box Set Name, type an appropriate name for your set (e.g. Totals).
4. Click on the Add Set button and then on Close.

To use the sets you have created, you need to activate them.

1. Click on Utilities and on Use Variable Sets.
2. In the list of variable sets, tick the set you have created (Totals) and then 

go up and untick the ALLVARIABLES option, as this would display all 
variables. Leave NEWVARIABLES ticked. Click on OK.
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With the sets activated, only the selected variables will be displayed in the data fi le and 
in the dialogue boxes used to conduct statistical analyses.

To turn the option off

1. Click on Utilities and on Use Variable Sets.
2. Tick the ALLVARIABLES option and click OK.

Data fi le comments
Under the Utilities menu, SPSS provides you with the chance to save descriptive 
comments with a data fi le.

1. Select Utilities and Data File Comments.
2. Type in your comments, and if you would like them recorded in the 

output fi le, click on the option Display comments in output. Comments 
are saved with the date they were made.

Display values labels in data fi le
When the data fi le is displayed in the Data Editor window, the numerical values for 
all variables are usually shown. If you would like the value labels (e.g. male, female) 
displayed instead, go to the View menu and choose Value Labels. To turn this option 
off, go to the View menu and click on Value Labels again to remove the tick.


